BaShare, un alternativa a HFS per Ubuntu

HFS (HTTP File Server) è un programma che permette di condividere files presenti sul proprio PC, fornendo un semplice link HTTP. Il problema è che questo software è rilasciato solo nella versione per Windows. E’ pur vero che è possibile installarlo sotto Ubuntu utilizzando Wine. Ma perché non ricorrere ad un programma nativo per Linux. Ricercando su internet ho scoperto BaShare, l’ho provato e l’ho trovato una valida alternativa a HFS per Ubuntu.

Per installarlo bisogna scaricare i seguenti tre pacchetti, e installarli nell’ordine:

1. pacchetto 1

2. pacchetto 2

3. pacchetto 3

Annunci

Ubuntu problemi webcam con skype e flash

Talvolta nonostante la propria webcam funziona normalmente con cheese, questa non funziona in programmi come skype o nelle webchat flash. Una lista delle soluzioni ai problemi con skype la si può trovare per vari modelli di webcam a questo indirizzo:
https://wiki.ubuntu.com/SkypeWebCams
Per quanto riguarda diversi modelli di telecamere, bisogna precaricari la libreria v4l1compat.so.
Per fare questo si deve accedere al terminale e scrivere:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype (per skype)
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so firefox (per firefox)

Si possono usare anche degli script.
Si apre gedit e si digita:

#!/bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

e si salva il file come skype.sh.
Per firefox si sostituirà la parola skype con firefox nel file e il nome del file sarà firefox.sh.
A questo punto si clicca con il tasto destro sul menu di gnome e quindi si sceglie modifica menù, si individua la voce skype o quella firefox e si clicca su proprietà. Quindi cliccando su esplora si trova la posizione del file skype.sh e si chiude.
Un ulteriore accortezza da usare è quella di dare i permessi di esecuzione a skype.sh. Per fare ciò si clicca con il tasto destro del mouse sul file skype.sh dal menù che si apre si sceglie proprietà e nella tab permessi si mette il segno di spunta su “consentire l’esecuzione del file come programma”.
La libreria v4l1compat.so potrebbe non essere installata, se cosi fosse, aprite il terminale e digitate:
sudo apt-get install libv4l-0